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Checking the correct operation of eToll
Albert Basiul avatar
Written by Albert Basiul
Updated over 7 months ago

Description of the issue: in case of receiving a call from a client or a message by mail with information that eToll does not work on the device, tolls will not be charged on the roads, it is necessary to check according to the descriptions below

Causes:
For checking the correct operation of eToll important check the correctness of the configuration, check activation in Puesc (using Postman), can be needed change configuration for fixing the incorrect operation of the tracker.

Actions:

  1. Get the device configuration following the instructions on Get device configuration file(request cfg) from device via LCM

  2. go to the "objects" tab, find our checked object and click on "View / Edit", after which it will be possible to find the "Current Profile" parameter in the opened object settings (you can use a quick search on the page Ctrl + F) -> activate the display this parameter and save the changes as shown in the photo.

    mceclip0.png
    mceclip1.png
  3. It is necessary from the tab with "Device cfg update" to find and copy the name of the client (most often it will correspond to the same name of the web-user). You need to find the specified client in the "web-users" tab as shown in the photo

    mceclip2.png
  4. Open the account of the found web user, find the vehicle being checked in the search menu or in the "fleet status" -> then go to the "history" tab and click on the button "->" analysis by coordinates

    mceclip3.png
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  5. Make sure the incoming data is correct. So, when located in Poland, for the eToll functionality to work correctly, the tracker must:

    -switch and be in 3 profiles.

    - at a speed greater than 0, the data transmission frequency should be at least every 5 seconds.

    mceclip5.png




  6. Possible problems :

    • the tracker may not be able to switch to profile 3 while in Poland à fixes the problem sending sms

    rpt reset

    on the example of the photo, you can see that at a speed of more than 0, being in 1 profile, the data transmission frequency was not every 5 seconds, but 40-60 seconds and more.

    After sending SMS

    rpt reset

    , the problem was fixed and everything began to work correctly.

    mceclip6.png

    proposed solution was primarily related to solving the problem of switching profiles (i.e. when the main problem was that the tracker in Poland should have been in profile 3, but it remained in profile 3).


  7. If the tracker is switched to profile 3 and at a speed of more than 0, if the tracker does not send data every 5 seconds -> most likely there is a problem with the connection method and settings and you need to change the configuration according to the photo below.

    Needed check configuration.

    Open cfg (which you got from request cfg):

    mceclip7.png
  8. If you have doubts about the correctness of connecting the tracker to the ignition, it is better to use the universal configuration as in the photo (needed set such configuration parameters for 1 and 3 profiles ):

    mceclip8.png
  9. Also needed activate in io events custom ignition for 1 and 3 profile (you can choose any disable slot and activate for it custom ignition) :

    mceclip9.png
  10. it is also important to make sure that all parameters are set as in the photo attached below

    1st profile:

    mceclip10.png



    3d profile:

    mceclip11.png



    for 1st and 3d profiles

    mceclip12.png
  11. save your new correct configuration

    mceclip13.png
  12. Add your configuration in device cfg add

    mceclip14.png
  13. Upload your cfg to the tracker in device cfg update

    mceclip16.png
  14. When your cfg successfully updated :

    mceclip17.png



    Needed send reset sms

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    Everything should now work correctly.

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