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Ride Share DEVICE_OFFLINE troubleshooting
Ride Share DEVICE_OFFLINE troubleshooting
Albert Basiul avatar
Written by Albert Basiul
Updated over 7 months ago

As of April 2022, there is a known issue regarding operation of the SM5 devices: [FWP-11531] [Ride Share] SM5 devices do not execute lock/unlock commands (DEVICE_OFFLINE) - Ruptela Jira (atlassian.net)

Related incidents can be merged into the main ticket #28258 until the solution is found. Consult with EU Global support for additional information.

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Description of the issue:

The Car sharing customer Ride Share (Spark) complains that the lock/unlock commands were not executed, system shows DEVICE_OFFLINE error.

Possible causes:

  • Operator issues;

  • Imperfections of the solution;

  • Firmware bug (needs investigation).

Troubleshooting steps:

1. Open the object and webuser according to Basic troubleshooting for Car sharing objects;

3. Check car sharing DCS commands and find the time when the incident happened:

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4. Open raw data report in TT2. Raw data report in Excel format takes longer to download but allows easier investigation (strongly recommended for deeper investigation):

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Note: In case Excel file is used, special color-coded formatting is recommended for easier visual identification. In the examples, a color-coded file will be used.

5. Check GPRS status in raw data.

In case GPRS state was "1" all day before and after the disturbance, register a query and consult with EU Global support. It can possibly mean several things:

  • Operator is not providing correct GPRS state;

  • Imperfection of the device operation (GPRS state did not update immediately during short disturbance of the operator);

  • Unknown firmware bug, preventing GPRS state from updating.

GPRS state was "0" during or around the time of disturbance, continue with troubleshooting:

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6. Check whether the operator switched around the time of disturbance:

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This information would help to determine whether the issue was related to the specific operator.

7. Check whether the temporary blacklist is enabled in the device configuration:

  • Checking DIFF files uploaded to the device (file should have "TBL" or similar tag:

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  • Checking the CFG file downloaded from the device (applicable for Global EU support);

  • Using SMS command (may not work in some configurations):

cspsm getcfg 144

8. Register a query and consult with EU Global support for further steps. Most likely, either an incident for the operator or JIRA task shall be created.

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